summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYorhel <git@yorhel.nl>2015-12-23 11:22:13 +0100
committerYorhel <git@yorhel.nl>2015-12-23 11:22:13 +0100
commit7cd0659ea033d74535550019bf09fa0437279fd0 (patch)
tree61154d6d107273ae323626991dd4c9c6b2dac545 /configure.ac
parentd9ebdd4921ed7f0c328b9606d90d1dc14ec11e9e (diff)
Better error reporting + handle SIGTERM/INT
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 07c1aac..d940c89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,6 @@ AC_CONFIG_HEADER([config.h])
AC_CONFIG_AUX_DIR([build-aux])
m4_include([deps/lean.m4])
AM_INIT_AUTOMAKE([foreign subdir-objects])
-PKG_PROG_PKG_CONFIG([0.18])
AC_PROG_CC
AC_PROG_INSTALL
@@ -45,9 +44,10 @@ if test "x$usesysev" != "xno"; then
usesysev=$havesysev
fi
if test "x$usesysev" = "xno"; then
- # Since we have our own libev, let's disable EV_MULTIPLICITY. Decreases
- # binary size a bit.
+ # Since we have our own libev, let's disable EV_MULTIPLICITY and threading
+ # support. Decreases binary size a bit.
AC_DEFINE(EV_MULTIPLICITY, 0, [Define to disable support for multiple event loops.])
+ AC_DEFINE(EV_NO_THREADS, 1, [Define to disable support for threads.])
m4_include([deps/ev/libev.m4])
fi
AM_CONDITIONAL([HAVE_SYSEV], [test "x$usesysev" = "xyes"])