summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..a5b8b13
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,24 @@
+
+AC_INIT([bdustest],[0.1],[projects@yorhel.nl])
+AC_CONFIG_SRCDIR([.])
+AC_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE([foreign subdir-objects])
+PKG_PROG_PKG_CONFIG([0.18])
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+AC_SYS_LARGEFILE
+
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+AC_DEFINE(EV_COMPAT3, 0, [Define to disable compatibility with pre-4.0 libev.])
+AC_DEFINE(EV_MULTIPLICITY, 0, [Define to disable support for multiple event loops.])
+m4_include([deps/ev/libev.m4])
+
+PKG_CHECK_MODULES([DBUS], [dbus-1])
+
+
+AC_OUTPUT([Makefile])
+