summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYorhel <git@yorhel.nl>2012-05-21 15:27:41 +0200
committerYorhel <git@yorhel.nl>2012-05-21 15:38:08 +0200
commit10e560a9a6cbcc8ebac69b43a5ee654f2947fd5d (patch)
tree2fdb63992da0f60968a6b581e5078386360298c0 /Makefile.am
parentae659d518675f28965924c80c3c246be0b82875a (diff)
Use top-level automake build + removed AUTHORS, INSTALL and NEWS
A more modern and practical structure.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am35
1 files changed, 34 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3920780..925056b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1 +1,34 @@
-SUBDIRS = src doc
+bin_PROGRAMS=ncdu
+
+ncdu_SOURCES=\
+ src/browser.c\
+ src/calc.c\
+ src/delete.c\
+ src/dirlist.c\
+ src/exclude.c\
+ src/help.c\
+ src/main.c\
+ src/path.c\
+ src/util.c
+
+noinst_HEADERS=\
+ src/browser.h\
+ src/calc.h\
+ src/delete.h\
+ src/dirlist.h\
+ src/exclude.h\
+ src/global.h\
+ src/help.h\
+ src/khash.h\
+ src/path.h\
+ src/util.h
+
+
+man_MANS=ncdu.1
+EXTRA_DIST=ncdu.1 doc/ncdu.pod
+
+# Don't "clean" ncdu.1, it should be in the tarball so that pod2man isn't a
+# build dependency for those who use the tarball.
+ncdu.1: $(srcdir)/doc/ncdu.pod Makefile
+ pod2man --center "ncdu manual" --release "@PACKAGE@-@VERSION@" "$(srcdir)/doc/ncdu.pod" >ncdu.1
+