summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorYorhel <git@yorhel.nl>2009-10-18 12:05:36 +0200
committerYorhel <git@yorhel.nl>2009-10-18 12:05:36 +0200
commitadaf8a609831734c41e89f386bdec83598a0912b (patch)
tree88e6b4318ad4f10316712c5e343dadbac748913a /configure.in
parent783993dbf5c7f86085c59b08a0faccc1bdf5f9d2 (diff)
Call setlocale() at initialization
This (in combination with linking to ncursesw) fixes the display of non-ASCII characters.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 18487a7..c4ee13e 100644
--- a/configure.in
+++ b/configure.in
@@ -11,7 +11,7 @@ AC_PROG_RANLIB
# Check for header files.
AC_CHECK_HEADERS(
- [limits.h stdlib.h string.h sys/time.h sys/types.h sys/stat.h dirent.h unistd.h fnmatch.h ncurses.h],[],
+ [limits.h stdlib.h string.h sys/time.h sys/types.h sys/stat.h dirent.h unistd.h fnmatch.h ncurses.h locale.h],[],
AC_MSG_ERROR([required header file not found]))
# Check for typedefs, structures, and compiler characteristics.
@@ -21,7 +21,7 @@ AC_STRUCT_ST_BLOCKS
# Check for library functions.
AC_CHECK_FUNCS(
- [getcwd gettimeofday memset fnmatch chdir rmdir unlink lstat getcwd],[],
+ [getcwd gettimeofday memset fnmatch chdir rmdir unlink lstat getcwd setlocale],[],
AC_MSG_ERROR([required function missing]))