summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryorhel <yorhel@ce56bc8d-f834-0410-b703-f827bd498a76>2007-07-20 11:15:46 +0000
committeryorhel <yorhel@ce56bc8d-f834-0410-b703-f827bd498a76>2007-07-20 11:15:46 +0000
commit6e3bbe69ee8ade74bdb2fe0528248a35c54a585c (patch)
tree6ec3af0c523de169e54b9bb422c100871ef21d0d /configure.in
Initial import (ncdu-1.1)v1.1
git-svn-id: svn://blicky.net/ncdu/trunk@1 ce56bc8d-f834-0410-b703-f827bd498a76
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in41
1 files changed, 41 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..c499ba5
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,41 @@
+
+AC_INIT(ncdu, 1.1, projects@yorhel.nl)
+AC_CONFIG_SRCDIR([src/ncdu.h])
+AC_CONFIG_HEADER([config.h])
+AC_PREFIX_DEFAULT(/usr)
+AM_INIT_AUTOMAKE
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+# Checks for libraries.
+AC_CHECK_LIB(ncurses, initscr)
+AC_CHECK_LIB(form, new_form)
+AC_CHECK_LIB(menu, new_menu)
+
+# Checks for header files.
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+AC_CHECK_HEADERS([limits.h stdlib.h string.h sys/time.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_OFF_T
+AC_SYS_LARGEFILE
+AC_STRUCT_ST_BLOCKS
+AC_HEADER_TIME
+
+# Checks for library functions.
+AC_FUNC_CLOSEDIR_VOID
+AC_FUNC_LSTAT
+AC_FUNC_MALLOC
+AC_FUNC_STAT
+AC_CHECK_FUNCS([getcwd gettimeofday memset])
+
+#AC_CONFIG_FILES([Makefile ])
+AC_OUTPUT([Makefile src/Makefile doc/Makefile])
+
+echo ""
+echo "Now type \"make\" and \"make install\" to build and install ncdu"