summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d2f745..369aa70 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,7 +51,7 @@ EXTRA_DIST=\
include_HEADERS=lib/ypc.h
-TESTS=test/str2sockaddr test/hex test/val_parse
+TESTS=test/str2sockaddr test/hex test/val_parse test/val
check_PROGRAMS=$(TESTS)
test_str2sockaddr_SOURCES=test/str2sockaddr.c lib/util/str2sockaddr.c lib/util/str2sockaddr_ip.c lib/util/str2sockaddr_port.c
test_str2sockaddr_CFLAGS=$(AM_CFLAGS)
@@ -59,6 +59,8 @@ test_hex_SOURCES=test/hex.c lib/util/hex2bin.c lib/util/bin2hex.c
test_hex_CFLAGS=$(AM_CFLAGS)
test_val_parse_SOURCES=test/val_parse.c
test_val_parse_LDADD=libypc.la
+test_val_SOURCES=test/val.c
+test_val_LDADD=libypc.la
MOSTLYCLEANFILES=ypc.dll ypc.lib ypc.exp ypc.pdb ypc.ilk *.obj
ACLOCAL_AMFLAGS=-I ac